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Webcast Captioning and Subtitling 
 
Webcasting, in simple terms, means streaming video on the web. You can stream a video that is already 
produced, or you can stream a live video in real time. 
 
When you caption or subtitle videos on the web (webcasting) you canreach out not only to the hearing 
impaired community, but also to people all over the world. You can put subtitles in virtually any 
language! You can take care of the language barrier and sound barrier at the same time! People from all 
over the world, no matter what language they speak, will be able to turn on the video and understand what 
is being said by choosing the subtitles in their own language. 
 
There are two scenarios for webcasting: 
 

• Video on Demand 
• Realtime Video 

 
When you a have a video in hand, you may upload the video on the web and people can see the video 
whenever they wish to. This is called Video on Demand Webcasting. On the other hand, if you want to 
webcast a live event, you may stream the live video on the web and people can watch the video as the 
event is in progress. This is called Realtime Video Webcasting. Typically broadcasters use this process to 
broadcast programs on the web. 
 
Captioning Realtime Webcasts 
CaptionMaker CPC-600 and 700 series are capable of captioning webcasts only for Video on Demand. 
This document will only explain webcasting for video on demand. The Realtime Video Webcasting is 
done by CPC-800 software. 
 
Captioning Video on Demand 
If you are considering webcasting, you will need to decide which format you will use, Windows Media 
Player, RealPlayer, QuickTime Player or Flash Player. Each offers different benefits and only you can 
decide which is best for your webcast. 
 
CaptionMaker can create files for all of these formats.  

Subtitle Examples: On our web site, www.cpcweb.com, we have a few sample demos 
under the link Webcasting. Check it out to get a better idea of subtitling a webcast. 

Inside the C:\Program Files\CPC\capmaker\Samples folder on your computer there are 
examples of webcast captions for all 4 players. You may take a look at these files to get 
some familiarity with these files. 

Captioning or Subtitling? 
Closed captioning on conventional video differs from subtitling on conventional video in several ways. 
The most important difference is that you can turn the captions on or off by choosing the closed caption 
option on the TV remote control. Closed captioning is used mostly by people who cannot hear well. 
Subtitling on conventional videos cannot be turned on or off. Subtitles are always on since they are part 
of the video. Subtitling is normally used by people who do not understand the language spoken in the 
video, so typically it appears in a language other than the language being spoken on the video. On 
conventional video media captions or subtitles appear on the bottom of the video. 
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Webcasting video on the web, a completely different medium, combines the concept of captioning and 
subtitling. The video appears in a small window on the computer screen and the text is displayed outside 
the area of the video. The viewer has a choice: 
 

• Turning the text on or off (on most players) 
• Switching between multiple languages (if multiple languages are present) 

 
Throughout this document we will use both terms “captioning” and “subtitling” interchangeably in 
relation to webcasting.  
 
Creating a Time-Stamped File 
To caption a webcast, your first task is to create a time-stamped file for the video. See Chapter 4 for 
details. 
 
RealPlayer can handle both Pop-on and Roll-Up display modes. Windows Media Player, QuickTime and 
Flash can handle Pop-On mode only. To play safe, follow these rules for all webcast exports. 

• use Pop-On display mode. 
• use upper and lower case, which is easy to read.  
• limit caption length to 32 characters.  
• position captions at the bottom of the screen. Since the captions are below the video, there is no 

need to place the captions at different vertical positions as is done in captioning a videotape to 
avoid graphics and other relevant information on the video.  

• position captions centered. 
• do not use music symbol. Use [music] instead of the music symbol. The music symbol does not 

appear as a music symbol in most players. 
 
Windows Media Player  
We recommend Windows Media Player for webcasting. It offers more options. Also everyone who uses a 
Windows computer will automatically have Windows Media Player, meaning that your viewers will not 
have to download new software to watch your video. There are four ways you can caption formats for 
Windows Media Player 

• Embedded Text  (browser independent) 
• ASX format (browser independent) 
• HTML Normal format (works with Internet Explorer only) 
• HTML Book Format (works with Internet Explorer only) 

 
Windows Media Player – Embedded Text 
 
In this method, the caption text is inserted inside the video file, there are no additional files for captioning. 
When you play the video in WPM, captions are extracted by WMP and are shown below the video. 
Windows Media Player - ASX Format 
You can also export a .smi file and a .asx file. The .smi file contains the text and timecode information. 
The .asx file is a short file, which pulls in the video and .smi file together to play within Windows Media 
Player. It does not matter which internet browser you use. It is browser independent.  
 
Two files .asx and .smi are created. Make a link to the .asx file to see the Webcast with captions. To test 
the files, place all files (.asx, .smi and .wmv) in one folder and double-click on the .asx file. The video 
will play and display the captions. 

 

No Need for ASX File !!! If the file names for the WM video file and the .smi file without 
the extensions are exactly the same, you really would not need the .asx file. When you 
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click on the .wmv file, WMP will see the .smi file with the same name and will pull the 
captions from the smi file. 

Windows Media Player – Html Format 
You can export captions for Media Player in HTML file format, which works with Internet Explorer only. 
Internet Explorer launches Windows Media Player and plays the video with captions. 
 
Two files .html and .smi are created. Make a link to the .html file to see the Webcast with captions. To 
test the files, place all files (.html, .smi and .wmv) in one folder and double-click on the .html file. The 
video will play and display the captions. 
 
Windows Media Player – Html Book Format 
In the Book format, a box is added next to the video with the full text. As the words are said, they are 
highlighted in the text box. This format works with Internet Explorer only. There is one advantage to this 
style. You may highlight the text with a mouse and copy and save the text on your hard drive. 
 
Three files .html, .dat  and .smi are created. Make a link to the .html file to see the Webcast with captions. 
To test the files, place all files (.html, .dat, .smi and .wmv) in one folder and double-click on the .html 
file. The video will play and display the captions. 
 

WMP Caption On/Off Switch To see captions on Windows Media Player, make sure to turn 
the captions on. For different versions of WMP, the steps to turn caption on are different. 
For details, check the link: www.cpcweb.com/wlive/WMPSwitches.html  

To export files for Windows Media Player, go to File → Export → Webcast- Media Player option.. You 
will see all the choices in the export window. 
 
The export window is self-explanatory.  Here are a few notes: 

• Do not use version 6 unless you know the viewer is going to use this old version WMP.  
• Version 7,8,9 also works for version 10 of WMP.  
• Make sure to jot down the time code of the first caption. 
• Choose size 12 Arial Bold font for clarity. 
• Check the box “Auto Size” unless you know the exact size of the video, like 320x240 

 

http://www.cpcweb.com/wlive/WMPSwitches.html


 
 
After exporting the file(s), upload the file(s) created by CaptionMaker and the video in the same folder on 
the web, and make a link to the appropriate file.  
 
 
Additional Notes on Windows Media Player  

• Captions do not move left and right 
• When working with the HTML exports, you have to open it in Internet Explorer.  Firefox 

will not open it correctly.  Also, most Internet Explorer pop-up blockers will block 
Active Content.  When the bar pops up that says Internet Explorer has blocked content, 
you have to click on the bar and Allow Blocked Content 

• It’s also important to remember to set your Caption Area Height large enough to 
accommodate multiple line captions.  When working with the HTML file, users have the 
option of viewing small or large text, so that has to be taken into account. 

 
RealPlayer  
RealPlayer is probably the easiest way to webcast, but some people may not have RealPlayer on their 
computer. The subtitles cannot be turned off from the RealPlayer options. The only way you can turn the 
subtitles off is to create a button on the web that plays the video without the subtitle files. Perhaps one 
day RealPlayer will have an option to turn the subtitles off or on as Windows Media Player does.  
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To export files for RealPlayer, go to File → Export → Webcast SMI/RT (*.zip) option to export the file. 
The Export Webcast dialog box opens up. 
 
The export window is self-explanatory.  Here are a few notes: 

• Make sure to jot down the time code of the first caption. 
• Choose size 12 Arial Bold font for clarity. 
• You can do rollup captioning with maximum of 10 lines of text in the text window. Make sure to 

adjust caption text height appropriately. 
 
 

 
 
 
After you export the file for RealPlayer, unzip the file and you will find three files. (If you use both Pop-
On and Roll-Up modes, you will have more than three files.)  
 

• video.rt 
• video.smi 
• videoweb.rm 

 
The .smi file contains the name of the video file you assigned in the export process. Let’s say the name of 
the file is video.rm 
 
The videoweb.rm file contains one line of text as below: 
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http://www.cpcweb.com/RealPlayer/Video.smi
 
This link (in this example) represents the following: 
 

• http://www.cpcweb.com is the web site where you would like to host this Webcast. 
• RealPlayer is the folder where you put all four files. 
• video.smi is the name of the .smi file described above. 

 
Now take these three files along with the RealPlayer video file video.rm and upload all four to your 
website folder RealPlayer and make a link to the file VideoWeb.rm and you are finished. When a web 
surfer clicks on this link, he will see the video with the subtitles. If you also would like to make a link just 
to see the video without the subtitles, simply make another link to the file video.rm 
 
Additional Notes on RealPlayer 

• Words move left and right, size and font can be changed in export options, size of the text 
track itself is customizable in export options. Do not use music symbol, use the word 
[music]. 

• Set the margins accordingly when doing right positioned captions.  If you don’t leave 
enough space in the margin for a right positioned caption, the words that don’t fit will be 
moved to the very left of the screen on the next line.  Setting margins to 0 works best, but 
you can get away with higher numbers depending on how your text is formatted. 

• Ignore the format for Roll-Up you used when creating the initial .cap file.  Upon export 
you will be asked to set the maximum number of lines for Roll-up mode.  If you enter 1, 
roll-up captions will appear one at a time, if you choose 5, then 5 roll-up captions will 
appear at once.  The only thing to remember is that you follow the warning and set your 
Caption Area Height accordingly to the font you’ve selected and the max number of lines 
you’ve set.  

 
 
 
 
 
QuickTime 
QuickTime is definitely the most difficult of the three programs for subtitling webcasts. Like RealPlayer, 
subtitles shown with QuickTime cannot be turned off or on. There are two ways you subtitle a QuickTime 
movie. 
 

• smi and text file format  
• Embedded text  

 
To export files for QuickTime, go to File → Export → QuickTime Webcast Script (*.txt) option.  You 
will get two files, one with extension .txt and the other with extension .smi 
 
SMI and text file format  
If you have the .smi, .txt and the video file .mov all in the same folder, open the .smi file in QuickTime 
and you will see the video with the captions. It is that simple. On the other hand if you want to embed the 
text inside the video, follow the steps below. 
  
Embedded Text 
 

1. Open QuickTime Player. 
2. Choose Open movie in new player and select the movie that you would like to subtitle. 

http://www.cpcweb.com/RealPlayer/Video.smi


3. Go to File → Import and choose the text file that has just been exported from CaptionMaker. 
(You may have to change the Type field from Movies to All). 

4. A new dialog box will open: Save converted file as. Click on Options in the bottom left corner. 
Here you can choose your font, font size, text style, screen width and height. You can also choose 
to do Keyed Text, which means that the text shows up right over the movie, not on a black 
background. Since this is just the text portion of the movie, you don’t want to make the height 
any bigger than 2-3 lines of text will require. Match the width with the width of the movie, and 
make the height just big enough for 2 lines of text (100-200 depending on your font size). You 
may have to try this a few times to get the right size. 

5. When you click on OK, a new movie will be created that contains only text. To go into this 
movie, go to Edit → Select All, then Edit → Copy. Now go into the movie that you would like to 
subtitle, and go to Edit → Add. You will see a black box at the top of the screen where the text 
should be. If you are using keyed text you will not see a black box; you may need to move 
forward a few seconds into the movie to see the text. But you probably don’t want a big box on 
the top of your movie, so you need to move it. 

6. Go to Movie → Get Movie Properties. A new dialog box will open. First, select the top left drop-
down menu and change it from Movie to Text Track. Now change the top right drop-down menu 
from Annotations to Size. When you click on Size, a new interface will open under the drop-down 
menus. Click on Adjust. 

 

 
 

 
7. A screen like the one above will open up. Click anywhere in the black area and drag it down so it 

is just out of the picture, so it looks like this:  
 

 
 

8. Now click on Done in the Movie Properties dialog box, save the file, and you are ready to upload 
the new .mov file to the web. 
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Additional Notes on QuickTime  

• If you make a stand-alone QuickTime movie with captions in Windows, you can enlarge 
the size of the video and the size and font of the text will actually change and get bigger 
to.  

 
Flash Player 
 
You will need these 4 things to do this: 

• CaptionMaker 
• Captionate (This is the program that will allow you to embed captions inside your .flv files.  You 

can find it here: http://www.buraks.com/captionate/6.html ) 
• Macromedia Flash Professional 8 or higher (This is the program that will allow you to build the 

.swf and/or .html files using your .flv video.  You can find it here: 
http://www.adobe.com/products/flash/ ) 

• Skins for FLVPlayback that support Captionate 
You can download them from the following link: 
http://blogs.adobe.com/accessibility/assets/CaptionedFLVSkins.mxp
Just double click the .mxp to install after you download 

 
Creating an .flv using Macromedia Flash 8 Video Encoder 

• If you purchased Flash Professional 8, it should come with Macromedia Flash 8 Video Encoder 
• You can use that to encode almost any type of video into an .flv file 
• Open Flash 8 Video Encoder, click Add, and choose your video  
• You can add as many videos as you want and the Video Encoder will convert all of them into .flv 

videos 
• If you don’t have any specific video settings you want to set, just use the default Medium Quality 

(400kbps) 
• After you have all your videos added in, just click Start Queue 

 
Creating an .xml using CaptionMaker 

• CaptionMaker cannot play .flv videos so use your original video to time, position, and format all 
your captions inside CaptionMaker 

• When you are finished, go to File >> Export DVD/DV2000/Webcast Subtitle and choose 
Webcast - Flash XML for Captionate from the pull down menu 

 
Combining the .xml with the .flv 

• Run Captionate and go to File >> Open and choose to open the .flv video you converted earlier 
• Go to File >> Import >> Captionate XML and choose the .xml file you just exported from 

CaptionMaker 
• After it imports all your captions in go to File >> Save 
• Now all of your captions are saved inside your .flv video 

 
Creating a .swf and an .html file using Macromedia Flash 

• Run Macromedia Flash and choose to start a new Flash Document 
• Make sure to save this project in the same folder as your .flv video 
• From the Components, & Actions, & Properties & Parameters panel, go to the Components tab  
• Expand FLV Playback – Player 8 and drag the FLVPlayback component from the tab into your 

work area 
• Now that you have a component to work with, go over to the Parameters tab and under Content 

Path put the full filename of your .flv (ex: MyVideo.flv).  You should not include the entire path 
to where your .flv is located.  Just put the name of the actual .flv 

• Then under Skin choose any skin that begins with the word Captioned 

http://www.buraks.com/captionate/6.html
http://www.adobe.com/products/flash/
http://blogs.adobe.com/accessibility/assets/CaptionedFLVSkins.mxp
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• After that you can go to Control >> Test Movie to see a sample of what your video will look like. 
• Press the CC button to turn your captions on or off 
• Once you are ready to create the final files go to File >> Publish Settings to confirm the names 

and types of files you want to export 
• Then go to File >> Publish to actually create them 

 
Playing your finished captioned flash videos 

• Make sure all 4 of the following files are in the same folder: 
1. The .flv video 
2. The .swf file for your video 
3. The .html file (for those who exported .html) 
4. The .swf file you chose as your skin 

• Then just double click the .swf file to bring up a player in flash, or double click the .html to bring 
up the flash player inside your web browser (IExplorer, Firefox, Safari, etc) 

 
Note 

• It is extremely important to remember that when you are building your project in Macromedia 
Flash that you do not include the entire path to your .flv in the Content Path section of the 
Parameters tab.  Doing so will make the video work perfectly fine on your computer, but it will 
not work for anyone else. 
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